错误描述:Net 开发WebService调用Microsoft..dll的服务器端对象模型,出现找不到网站的应用程序,或者出现500错误。

错误截图:

Sharepoint 如何自定义WebService 找不到网站应用程序

[Webservice调用页错误]

System.IO.FileNotFoundException: 找不到位于 http://localhost 的 Web 。请确认正确键入了此 URL。如果此 URL 需要提供现有内容,则系统管理员可能需要添加到指定应用程序的新请求 URL 映射。 在 ..SPSite..ctor(SPFarm farm, Uri requestUri, Boolean contextSite, SPUserToken userToken) 在 Microsoft.SharePoint.SPSite..ctor(String requestUrl) 在 WebApplication1.WebService1.GetWebID(String SiteUrl) 位置 C:UsersAdministratorDocumentsVisual Studio 2010ProjectsWebApplication1WebApplication1WebService1.asmx.cs:行号 26

[完整的错误提示]

[WebMethod(Description = "获取WebID")]

public string GetWebID(string SiteUrl)

{

      SPSite site = null;

     SPWeb web = null;

     site = new SPSite(SiteUrl);

      web = site.OpenWeb();

      return "ID:" + web.ID.ToString();  

}

[测试代码,获取WebID]

  最初以为是备用访问映射,或者修改Host文件的问题,因为找不到应用程序么,然后在浏览器里打开url,发现可以打开;再考虑是不是权限不够,因为是net调用sharepoint的dll,然后提权进行操作,发现也不能解决问题。

  查了很久,后来发现,代码预览有问题,但是发布以后,调用WebService却没有问题,感觉很奇怪,但是没有办法进行调试了。后来查资料,发现说VS的iis对64位支持有问题,虽然自己并不清楚是不是这里的问题,但是发布以后,调试本机的iis,发现问题不存在了(感谢这位博主的文章,参考博文地址附后)。

解决方法: 把自己建的项目发布到本地iis,然后 属性 – web – 使用本地iis web服务器,填写格式[url:port/网站名称],然后可以调试了。

Sharepoint 如何自定义WebService 找不到网站应用程序

  修改以后,发现调用的时候,还有抛黄页的现象[“拒绝访问。 (异常来自 HRESULT:0x80070005 (E_ACCESSDENIED))”],后来,经朋友提醒,发现木有提权,菜鸟就是菜鸟,之前调试的晕头转向,居然忽略了提权。

提权代码:

SPSecurity.RunWithElevatedPrivileges(delegate()
{

代码段….
});

  再有就是,有人说写控制台,也会出现找不到应用程序的情况,将生成的目标平台调成64位,或者调成[Any cpu],自己到没有遇到过,不过这些对WebService调用sharepoint.dll是不管用的。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注