On July 30, 2021you may encounter log-in issues if you haven’t updated your Power BI cmdlets.

To avoid log-in failure, you will need to update Power BI Cmdlet module MicrosoftPowerBIMgmt to version 1.0.946 or greater prior to July 30, 2021.

Due to security requirements, we have made changes to the way the cmdlets talk to Azure Active Directory. As a result, MicrosoftPowerBIMgmt versions older than 1.0946 will error out during the login flow.

How this will affect your organization:

You are receiving this message because our reporting indicates one or more users in your organization are using these cmdlets.

What you need to do to prepare:

This change will start to roll out on July 30th, so please upgrade your MicrosoftPowerBIMgmt version before that date to avoid any disruptions.

To find out what version of the module you have, run this command in Windows PowerShell:

PS C:\windows\system32> Find-Module -Name MicrosoftPowerBIMgmt

Version Name Repository Description
———- ——– ————– —————
1.2.0 MicrosoftPowerBIMgmt PSGallery Microsoft Power BI PowerShell – All cmdlets for Microsoft Power BI

Note: If the version number is equal or greater than 1.0946, then no action is required or needed.

 

Before this change takes effect, you will need to update the module by simply opening the Windows PowerShell (admin), and executing the following command:

Update-Module -Name MicrosoftPowerBIMgmt.

 

2021 年 7 月 30日,如果您尚未更新电源 BI cmdlet,可能会遇到登录问题。

为了避免登录失败,您需要在2021 年 7 月 30日之前将电源 BI Cmdlet 模块MicrosoftPowerBIMgmt更新为版本 1.0.946 或更高版本。

由于安全要求,我们更改了 cmdlet 与 Azure 活动目录的通话方式。因此,超过 1.0946 的 微软电源BIMgmt 版本将在登录流中出错。

这将如何影响您的组织:

您收到此消息,因为我们的报告表明您组织中的一个或多个用户正在使用这些 cmdlet。

您需要做什么来准备:

此更改将于 7 月 30 日开始推出,因此请在该日期之前升级您的 MicrosoftPowerBIMGMt 版本,以避免任何中断。

要了解您拥有的模块的哪个版本,请在 Windows 电源壳中运行此命令:

PS C:\窗口\系统32>查找模块-名称 微软电源

版本 名字 存储 库 描述
———- ——– ————– —————
1.2.0 微软电源 普斯画廊 微软电源BI电源壳-微软电源BI的所有厘米

注意:如果版本编号相等或大于 1.0946,则不需要或不需要任何操作。

 

在此更改生效之前,您需要只需打开 Windows 电源壳(管理员)并执行以下命令来更新模块:

更新模块-名称 微软电源比姆。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注