话说本来我的电脑有个2000的数据库,去年我在那个电脑上新装了一个2005的数据库。前不久我买了台新电脑,装了数据库2008 将在旧电脑上的一个数据库附加到了2008上面。做完项目,将数据库传到空间时,空间数据库是2000的,报错说我的数据库是2005的 现在我想把我的数据库转成2000,但是我的2008数据库的脚本向导里面没有转成2000这个选项,2005的版本又附加不上去。

关于这个问题,上网请教了网友,真实人多力量大,给出了一系列答案,下面就为大家整理的内容,希望可以帮助大家解决SQLServer数据库从高版本降级到低版本的问题。

网友DBA_Huangzj 给出的解决方法:

步骤1:

 MS sqlserver 2008数据库转换成2000版本的方法

步骤2:

MS sqlserver 2008数据库转换成2000版本的方法

步骤3:把脚本拖到2000的查询分析器界面,然后点运行,2000以前的我不清楚,但是从2000开始的所有SQLServer版本F5都是运行的意思….你不会没用过SQLServer吧?生成完之后 。

步骤4:按照我文章中的那个步骤的截图打开导入导出工具,然后一直点下去,注意在【目标服务器】那里填写2000的那个实例名,然后到这个地方全选,再点下一步。

MS sqlserver 2008数据库转换成2000版本的方法

步骤5:点完成。

MS sqlserver 2008数据库转换成2000版本的方法

然后基本上就完事了。

但是这里注意,因为你从2008直接降到2000,跨度很大,而且2000~2005是个大跨越,多处很多兼容性的问题,所以不排除你在生成脚本及导数据的时候会存在报错(并且可能性比较大!),如果有,那你要手动去除那些报错的,然后记下来,继续运行不报错的,最后再手动创建那个报错的。

补充一句,比较稳妥的办法是在生成脚本时,先生成表的,也就是在步骤2中的【选择对象】那里选表,然后生成脚本,成功了,再生成其他比如存储过程等。

以上就是本文的全部内容,谢谢网友的分享,希望对大家的学习有所帮助,也希望大家多多支持沃谷博客。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注